ACS Applications Maintenance
Scheduled
2025-07-20T00:11:00.0000000Z
ACS Applications Maintenance
Status: closed
Start:
2025-07-19T22:30:00.0000000Z
End:
2025-07-20T00:11:00.0000000Z
Duration: 1 hour 41 minutes
Affected Components:
Other
Update
2025-07-19T22:30:00.0000000Z
2025-07-19T22:30:00.0000000Z
UAB IT will be pushing updates to the following applications
on Saturday, July 19th from 5:30 p.m. to 6:00 p.m.
·
Position Authorization/Compensation Request Form
(PAR/CRF)
·
Discrimination Complaint Form
·
UAB-Related International Travel Registration
Resolved
2025-07-20T00:11:00.0000000Z
2025-07-20T00:11:00.0000000Z
The maintenance is now complete.