myUAB Portal Updates
Scheduled
upcoming
30 minutes
2025-05-03T02:00:00.0000000Z
myUAB Portal Updates
Status: upcoming
Start:
2025-05-03T02:00:00.0000000Z
Estimated Duration: 30 minutes
Affected Components:
Other
Update
2025-05-03T02:00:00.0000000Z
2025-05-03T02:00:00.0000000Z
Updates will be deployed for the myUAB Portal (my.uab.edu) on Friday evening, May 2, from 9:00 p.m. to 9:30 p.m. The Portal may be unavailable intermittently during the maintenance window